我们很高兴地通知大家,天狼星主网将从0.4.3版升级到0.6.2版。

我们强烈建议所有天狼星链节点拉取0.6.2版本的docker映像进行升级。

究竟会发生生么

将有两个升级,软件和配置升级。 该软件升级将安装以下修补程序,作为天狼星 0.6.2的一部分

技术说明

超级合约激活

重做区块难度计算

改进的配置文件实施

修复了交易所patricia树和交换所插件中的几个错误

更新了回滚块上的缓存高度 修复了节点选择中的死锁

配置升级将引入新的模块规格,这些规格与即将推出的天狼星存储和天狼星超级合约主网发布直接相关。

ProximaX团队会进行的事项

运行升级机制脚本。

将内部节点升级到0.6.2

确保天狼星链SDK参考实施是最新的。

冒烟测试天狼星钱包和资源管理器。

冒烟测试分散交换机制。

需要采取的行动

对于公共验证节点,我们强烈建议公共天狼星链验证器参与者升级其节点。 请注意,如果参与者节点升级失败,则该节点将无法验证区块。 请按照此处指示的步骤进行操作。

此外,我们还要强调使用委托或多重签名作为验证者密钥的重要性。 在验证者节点上关联权益的最佳方法是使用委托验证。 它确保将存有代币的帐户与验证者节点分离,从而保护帐户密钥免受验证者节点上的任何未授权访问。

对于天狼星链软件开发套件开发人员,SDK参考实现已进行了调整,以反映天狼星链的新变化。 为此,请在您各自的SDK上进行必要的调整。 SDK参考实现可在此处查看。

对于外部天狼星链项目所有者,强烈建议使用0.6.2版本,因为它解决了关键的稳定性问题。 请确保您评估并考虑为此创建迁移/升级计划。

对于开发人员,请确保获得最新的SDK版本。 天狼星链接口终端没有重大变化,只有SDK需要包装的其他变化。 确保在您的应用程序上进行了适当的迁移。

下一步

我们将等待一个月左右的时间来监视天狼星链的稳定性。 在对区块生成产生足够的信心之后,我们将为天狼星存储和天狼星超级合约主网络发布做准备。 这将需要配置升级以启用插件。

关于开放天狼星的源码,我们将在升级后不久开放服务器和REST-API的源码,以允许外部各方使用我们的代码。 整个Sirius链的设计都具有插件机制,并允许与主流技术集成。